Showing results for 
Search instead for 
Do you mean 
Reply

48 abroad

Average Joe
Posts: 1
‎06-02-2018 12:13 AM
Have done all what I am meant to have done, on guido, changed the network selection before I left but still not working. When I go into cellular and turn off automatic I get a list of O2 UK and 3 UK etc but when I click them it still says no service. Using iPhone SE
Posted from Apple iPhone
Reply
0 Likes

Re: 48 abroad

The Legend
Posts: 13,941
‎06-02-2018 07:16 AM
You mean you did this and it's still not working?

https://community.48months.ie/t5/Most-Popular-Questions/iPhone-abroad-issue/td-p/36862%C2%A0

Are you sure that you have roaming enabled?

If so and you still can't get it working then you'll probably have to contact 48 support for assistance.

Hope this helps.


I am not a 48 employee so if you need to contact 48 support then use option 3 or the chat facility here.
Posted from Xiaomi Redmi Note 3
Reply
0 Likes

Announcements
If you haven't already registered, now is a good time to do so. Register now >>
Order a free SIM
Earn some extra credit or cash with MatesRates!
Unlock your phone
Ask the community